Friday, March 26, 2010

Free Secure Wallet


Free Secure Wallet is a free mobile application build by J2ME



Used for storing sensitive data on mobiles (secure notepad) like Credit card, password and all sensitive data that should be kept secure.

The application provide a lot of security measures like log in password, encode stored data for more security , expire session after 30 min. (since version 1.2 this is configurable feature)

It is working on all J2ME platforms with MIDP 2.0 and CLDC 1.0. It support Arabic/English languages for the interface, But stored data should be English.

*Since version 1.1 a newly added feature which is "Forced Password Set" this allow you to set a password that can be used to open the application in case you are forced for that, it open the application with no entries displayed.

*Since version 1.2 , you have the option to list the items sorted or not sorted.

*Now in version 2.0, you have the ability to export the data into the device memory than re-import them on another device but after providing the same password used in export them, so you can change your device and keep your data move easily.


The Application Version 2.0 can be downloaded from the URL :

http://www.getjar.com/mobile/27360/free-secure-wallet/


Any suggested features will be considered in subsequent releases.

19 comments:

  1. very very good for me this piece of programm. THANKS a lot!

    Please what is the encription/encoding method used for: AES, Blowfish or what else?
    Thanks
    Nick
    nic_apo@yahoo.com

    ReplyDelete
  2. This is some variant from one-time-pad, between your password and date

    ReplyDelete
  3. I am habib from IRAN
    this is very good freeware and i use this a lot.
    thank you very much.

    ReplyDelete
  4. I have version 1.2 of Secure Wallet on my Motorola RAZR V3 and it works perfect. But I wanna try 2.0 and I downloaded from mobile24.com and when I installed on my RAZR V3 and start it, my phone says Application Error. So my question is: If 1.2 works perfect on my phone why I get this message with 2.0 version? Is it a different structure from 1.2 or there is various versions depending on that what phone u use?. Thank you in front.

    Boris, Republic of Macedonia.

    ReplyDelete
  5. Simply the newly added features in version 2.0 is export/import into file the secure wallet content, so you can change your mobile.
    If FILE APIs is not supported in your mobile the application install will unfortunately fail.

    ReplyDelete
  6. Osama, I did check for Motorola RAZR V3 what is supported and I get this:
    -----------------------------------------------
    Java version supported:
    MIDP 2.0 (JSR 120),
    MMA (JSR 135),
    file sy8stem API,
    J2ME application shortcuts, apps can run in background.
    -----------------------------------------------

    Is this ok for running FSW 2.0 on the phone?

    Boris, Republic of Macedonia.

    ReplyDelete
  7. It should be enough.
    You may just need to check the application manager and give the application file system APIs permissions.

    ReplyDelete
  8. Nope, still have the same problem, I add all permisions, and still the same: Application Error, on runing it.
    It's ok, I'm very satisfied with version 1.2, it do the job so far, hope in the future too.

    Greetings to you my friend.

    Boris, Republic of Macedonia

    ReplyDelete
  9. I am sorry for that, you can still use 1.2 but if you changed the mobile you will need to do it manual migration.

    ReplyDelete
  10. I have a Satio u1a with Free Secure Wallet (v2.0). It appears that there is no support for Nokia N9, at this time. Can and will you offer support for the N9, in the foreseeable future? Do you have a compliant version, currently? Thanks.

    ReplyDelete
  11. Will look forward to your response to my earlier inquiry, today, regarding Free Secure Wallet and compliance with Nokia N9, via email. Thanks.

    ReplyDelete
  12. Is it not working ? Any error show ? this need only J2ME support and it should be available in N9.

    ReplyDelete
  13. GetJar indicates "incompatible application" on download attempt, having selected device N9 as required, hence my inquiry to you. By the way, thanks for a great tool, Osama!

    ReplyDelete
  14. Download it to the PC then send it to you N9, because when i published it , there was no N9 in the options :) ...

    ReplyDelete
  15. I have been using this application since long time. Very useful..Thanks..

    ReplyDelete
  16. I am Bhaskar from Qatar. This is a very useful application. Thanks to you. Is it possible to export my data's to my Laptop as to backup in case of something happens to my phone. Please advice.

    ReplyDelete
  17. Hi Bhaskar, Sure you can by exporting it into the external memory then connect it to the PC and store the file..

    ReplyDelete
  18. One issue has been found: login expiration DOES work OK, but after login expires you still see the last open SECRET :) entry on the screen, of course you can not switch to any other entry. So... this issue is kinda risky bug :)

    ReplyDelete
    Replies
    1. Yes, it seems bug it need small fix , let me know if you need it i can send the fixed app to you.

      Delete